Saturday , November 17 2018
Home / Tag Archives: Huawei S5700

Tag Archives: Huawei S5700

PIM SM on Huawei S5700

I wanted to use AR routers to prepare PIM SM lab but it turned out that there is a problem with cooperation between multicast source and AR router. Of course I am talking about network simulator eNSP. Finally I decided to use eNSP with S5700. So we have topology like in the last two posts:

  1. Configure VLANs, VLAN interfaces and IP addresses based on the topology (omitted).
  2. Configure OSPF to ensure connectivity between switches (omitted).
  3. Enable multicast on both switches.
  4. Enable PIM SM on all interfaces.
  5. Enable IGMP on receivers’ interfaces.
  6. Set static RP for both switches (Loopback0 of SwitchB).
  7. Address of multicast group G: 225.1.1.1.
  8. Address of multicast group S: 10.10.10.100.

Read More »

PIM DM on Huawei S5700

PIM DM topology on Huawei S5700

  1. Configure IP addresses based on the above topology (omitted).
  2. Use OSPF to assure connectivity between switches.
  3. Enable multicast on both switches.
  4. Enable PIM DM on all interfaces.
  5. Address of multicast group G: 225.1.1.1.
  6. Address of multicast group S: 10.10.10.100.

OSPF configuration:

Read More »

How to manage files through SCP on Huawei

SCP is a secure file transfer, based on SSH2.0, which supports downloading and uploading files between SCP client and server, in batches as well. If you would like to know more, just visit Huawei support website. I will focus on practice and show this feature, using simple lab:

Configure communication between loopback interfaces of the server and the client. Below the SCP_server as an example. As this is a simple topology, I used RIP protocol for communication (long unused by me):

#
sysname SCP_server
#
vlan batch 100
#
interface Vlanif100
 ip address 10.1.1.1 255.255.255.0
#
interface MEth0/0/1
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 100
#
interface LoopBack0
 ip address 1.1.1.1 255.255.255.255
#
rip 1
 network 10.0.0.0
 network 1.0.0.0
#

Read More »

Link Flapping Protection on Huawei switches

I have come across link flapping protection feature recently. It is available on S5700 switches. It looks like it is a new feature on Huawei switches. I had not met it in older hardware versions. That’s why I decided to write a few words about it. Unfortunatelly, although this command is available in Huawei network simulator eNSP, it does not work properly. But maybe you will have possibility check it on your real devices.

Port flapping (port going UP and DOWN continually) can be caused by a faulty cable, link failure, active/standby switchover, port hardware failure, etc. Frequent status changes on an interface can lead to:

  • STP topology recalculation and changes,
  • ARP entries updates,
  • dynamic routing instability and convergence problems.

All these issues can negatively affect switch performance and should be avoided.

Link Flapping Protection is a feature that can be implemented on an interface to solve problems caused by the flapping port or link. It checks the interface flapping frequency and link flapping detection interval. If the number of interface flapping times reaches the limit, in a specified period, the interface is shut down.

Read More »